using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[0-9]+/[A-Za-z0-9]+_((?=14-Sep-2015)).*";
string input = @"bucket/123/CODE_13-Sep-2015.txt
bucket/123/CODE_14-Sep-2015.txt
bucket/123/CODE_15-Sep-2015.txt";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}