import re
regex = re.compile(r"[0-9]+/[A-Za-z0-9]+_((?=14-Sep-2015)).*")
test_str = ("bucket/123/CODE_13-Sep-2015.txt\n"
"bucket/123/CODE_14-Sep-2015.txt\n"
"bucket/123/CODE_15-Sep-2015.txt")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")