import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[0-9]+/[A-Za-z0-9]+_((?=14-Sep-2015)).*";
final String string = "bucket/123/CODE_13-Sep-2015.txt\n"
+ "bucket/123/CODE_14-Sep-2015.txt\n"
+ "bucket/123/CODE_15-Sep-2015.txt";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}