re = /[0-9]+\/[A-Za-z0-9]+_((?=14-Sep-2015)).*/
str = 'bucket/123/CODE_13-Sep-2015.txt
bucket/123/CODE_14-Sep-2015.txt
bucket/123/CODE_15-Sep-2015.txt'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end