#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\w+_work_\d{3}.blob.obj"
Local $sString = "online_work_000.blob.obj" & @CRLF & _
"online_work_001.blob.obj" & @CRLF & _
"online_work_002.blob.obj" & @CRLF & _
"online_work_003.blob.obj"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")