$re = '/\w+_work_\d{3}.blob.obj/';
$str = 'online_work_000.blob.obj
online_work_001.blob.obj
online_work_002.blob.obj
online_work_003.blob.obj';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);