import Foundation
let pattern = #"\w+_work_\d{3}.blob.obj"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
online_work_000.blob.obj
online_work_001.blob.obj
online_work_002.blob.obj
online_work_003.blob.obj
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}