re = /\w+_work_\d{3}.blob.obj/
str = 'online_work_000.blob.obj
online_work_001.blob.obj
online_work_002.blob.obj
online_work_003.blob.obj'
# Print the match result
str.match(re) do |match|
puts match.to_s
end