// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\w+_work_\d{3}.blob.obj").unwrap();
let string = "online_work_000.blob.obj
online_work_001.blob.obj
online_work_002.blob.obj
online_work_003.blob.obj";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}