package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\w+_work_\d{3}.blob.obj`)
var str = `online_work_000.blob.obj
online_work_001.blob.obj
online_work_002.blob.obj
online_work_003.blob.obj`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}