# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:10\.31\.(?:6|7)\.\d{1,3}|\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})//;t' <<< "10.31.7.1
10.31.7.1
"