using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:10\.31\.(?:6|7)\.\d{1,3}|\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})";
string substitution = @"";
string input = @"10.31.7.1
10.31.7.1
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}