package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:10\.31\.(?:6|7)\.\d{1,3}|\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})`)
var str = []byte(`10.31.7.1
10.31.7.1
`)
var substitution = []byte("")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}