const regex = new RegExp('(?:10\\.31\\.(?:6|7)\\.\\d{1,3}|\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}\\.\\d{1,3})', '')
const str = `10.31.7.1
10.31.7.1
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);