import re
regex = re.compile(r"(?:10\.31\.(?:6|7)\.\d{1,3}|\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})")
test_str = ("10.31.7.1\n\n"
"10.31.7.1\n\n")
subst = ""
result = regex.sub(subst, test_str, count=1)
if result:
print(result)