re = /(?:10\.31\.(?:6|7)\.\d{1,3}|\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})/
str = '10.31.7.1
10.31.7.1
'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result