// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:10\.31\.(?:6|7)\.\d{1,3}|\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})").unwrap();
let string = "10.31.7.1
10.31.7.1
";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}