# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<\\/?(?!img|a)[^>]+>//g;t' <<< " <p>So in this</p>
<p>HTML <strong>with nested tags</strong></p>
<p>It should remove <i>everything</i> except <a href=\"#\">This link</a>
and this <img src=\"#\" alt=\"image\" /> but it also needs to kep the textual content</p>"