use strict;
my $str = ' <p>So in this</p>
<p>HTML <strong>with nested tags</strong></p>
<p>It should remove <i>everything</i> except <a href="#">This link</a>
and this <img src="#" alt="image" /> but it also needs to kep the textual content</p>';
my $regex = qr/<\/?(?!img|a)[^>]+>/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";