import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<\\/?(?!img|a)[^>]+>";
final String string = " <p>So in this</p>\n"
+ " <p>HTML <strong>with nested tags</strong></p>\n"
+ " <p>It should remove <i>everything</i> except <a href=\"#\">This link</a>\n"
+ " and this <img src=\"#\" alt=\"image\" /> but it also needs to kep the textual content</p>";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}