re = /<\/?(?!img|a)[^>]+>/
str = ' <p>So in this</p>
<p>HTML <strong>with nested tags</strong></p>
<p>It should remove <i>everything</i> except <a href="#">This link</a>
and this <img src="#" alt="image" /> but it also needs to kep the textual content</p>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result