#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "<\/?(?!img|a)[^>]+>"
Local $sString = " <p>So in this</p>" & @CRLF & _
" <p>HTML <strong>with nested tags</strong></p>" & @CRLF & _
" <p>It should remove <i>everything</i> except <a href="#">This link</a>" & @CRLF & _
" and this <img src="#" alt="image" /> but it also needs to kep the textual content</p>"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)