using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<\/?(?!img|a)[^>]+>";
string substitution = @"";
string input = @" <p>So in this</p>
<p>HTML <strong>with nested tags</strong></p>
<p>It should remove <i>everything</i> except <a href=""#"">This link</a>
and this <img src=""#"" alt=""image"" /> but it also needs to kep the textual content</p>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}