#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?:<ul>)?(\s*<li class="myclass">(.+)<\/li>\s*)(?:<\/ul>)?"
Local $sString = "<ul>" & @CRLF & _
" <li class="myclass">blablabla 1</li>" & @CRLF & _
" <li class="myclass">blablabla 2</li>" & @CRLF & _
" <li class="myclass">blablabla 3</li>" & @CRLF & _
"</ul>"
Local $sSubst = "<div class="newClass">$2</div>\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)