const regex = /(?:<ul>)?(\s*<li class="myclass">(.+)<\/li>\s*)(?:<\/ul>)?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:<ul>)?(\\s*<li class="myclass">(.+)<\\\/li>\\s*)(?:<\\\/ul>)?', 'g')
const str = `<ul>
<li class="myclass">blablabla 1</li>
<li class="myclass">blablabla 2</li>
<li class="myclass">blablabla 3</li>
</ul>`;
const subst = `<div class="newClass">$2</div>\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);