re = /(?:<ul>)?(\s*<li class="myclass">(.+)<\/li>\s*)(?:<\/ul>)?/
str = '<ul>
<li class="myclass">blablabla 1</li>
<li class="myclass">blablabla 2</li>
<li class="myclass">blablabla 3</li>
</ul>'
subst = '<div class="newClass">$2</div>\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result