using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:<ul>)?(\s*<li class=""myclass"">(.+)<\/li>\s*)(?:<\/ul>)?";
string substitution = @"<div class=""newClass"">$2</div>\n";
string input = @"<ul>
<li class=""myclass"">blablabla 1</li>
<li class=""myclass"">blablabla 2</li>
<li class=""myclass"">blablabla 3</li>
</ul>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}