import re
regex = re.compile(r"(?:<ul>)?(\s*<li class=\"myclass\">(.+)<\/li>\s*)(?:<\/ul>)?")
test_str = ("<ul>\n"
" <li class=\"myclass\">blablabla 1</li>\n"
" <li class=\"myclass\">blablabla 2</li>\n"
" <li class=\"myclass\">blablabla 3</li>\n"
"</ul>")
subst = "<div class=\"newClass\">$2</div>\\n"
result = regex.sub(subst, test_str)
if result:
print(result)