import Foundation
let pattern = #"(?:<ul>)?(\s*<li class="myclass">(.+)<\/li>\s*)(?:<\/ul>)?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<ul>
<li class="myclass">blablabla 1</li>
<li class="myclass">blablabla 2</li>
<li class="myclass">blablabla 3</li>
</ul>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<div class="newClass">$2</div>\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)