// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?:<ul>)?(\s*<li class="myclass">(.+)<\/li>\s*)(?:<\/ul>)?"#).unwrap();
let string = "<ul>
<li class=\"myclass\">blablabla 1</li>
<li class=\"myclass\">blablabla 2</li>
<li class=\"myclass\">blablabla 3</li>
</ul>";
let substitution = "<div class=\"newClass\">$2</div>\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}