# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<[^>]*>/'1'/g;t' <<< "WHERE Y_W_N IN (<er,0>,<ER,-52>,<er,-1>) AND cat IN ('something sales','movies')"