import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<[^>]*>";
final String string = "WHERE Y_W_N IN (<er,0>,<ER,-52>,<er,-1>) AND cat IN ('something sales','movies')";
final String subst = "'1'";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}