const regex = /<[^>]*>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<[^>]*>', 'g')
const str = `WHERE Y_W_N IN (<er,0>,<ER,-52>,<er,-1>) AND cat IN ('something sales','movies')`;
const subst = `'1'`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);