import Foundation
let pattern = #"<[^>]*>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"WHERE Y_W_N IN (<er,0>,<ER,-52>,<er,-1>) AND cat IN ('something sales','movies')"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"'1'"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)