use strict;
my $str = 'WHERE Y_W_N IN (<er,0>,<ER,-52>,<er,-1>) AND cat IN (\'something sales\',\'movies\')';
my $regex = qr/<[^>]*>/p;
my $subst = '\'1\'';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";