# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^\S+\s+)|\s+(?=\S+$)/`/g;t' <<< "ABC DEF SASF 123 (35)"