$re = '/(^\S+\s+)|\s+(?=\S+$)/';
$str = 'ABC DEF SASF 123 (35)';
$subst = "`";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;