const regex = /(^\S+\s+)|\s+(?=\S+$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^\\S+\\s+)|\\s+(?=\\S+$)', 'g')
const str = `ABC DEF SASF 123 (35)`;
const subst = `\``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);