import re
regex = re.compile(r"(^\S+\s+)|\s+(?=\S+$)")
test_str = "ABC DEF SASF 123 (35)"
subst = "`"
result = regex.sub(subst, test_str)
if result:
print(result)