use strict;
my $str = 'ABC DEF SASF 123 (35)';
my $regex = qr/(^\S+\s+)|\s+(?=\S+$)/p;
my $subst = '`';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";