re = /(^\S+\s+)|\s+(?=\S+$)/
str = 'ABC DEF SASF 123 (35)'
subst = '`'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result