using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^\S+\s+)|\s+(?=\S+$)";
string substitution = @"`";
string input = @"ABC DEF SASF 123 (35)";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}