#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(^\S+\s+)|\s+(?=\S+$)"
Local $sString = "ABC DEF SASF 123 (35)"
Local $sSubst = "`"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)