# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/throw new UserException\('(.*)'\)/throw new UserException("$1");/g;t' <<< "throw new UserException('test');
throw new UserException('require');
throw new UserException('working');
throw new UserException('okay');
throw new UserException('regular');
throw new UserException('works!');"