// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"throw new UserException\('(.*)'\)").unwrap();
let string = "throw new UserException('test');
throw new UserException('require');
throw new UserException('working');
throw new UserException('okay');
throw new UserException('regular');
throw new UserException('works!');";
let substitution = "throw new UserException(\"$1\");";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}