use strict;
my $str = 'throw new UserException(\'test\');
throw new UserException(\'require\');
throw new UserException(\'working\');
throw new UserException(\'okay\');
throw new UserException(\'regular\');
throw new UserException(\'works!\');';
my $regex = qr/throw new UserException\('(.*)'\)/p;
my $subst = 'throw new UserException("$1");';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";