import Foundation
let pattern = #"throw new UserException\('(.*)'\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
throw new UserException('test');
throw new UserException('require');
throw new UserException('working');
throw new UserException('okay');
throw new UserException('regular');
throw new UserException('works!');
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"throw new UserException("$1");"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)