import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "throw new UserException\\('(.*)'\\)";
final String string = "throw new UserException('test');\n"
+ "throw new UserException('require');\n"
+ "throw new UserException('working');\n"
+ "throw new UserException('okay');\n"
+ "throw new UserException('regular');\n"
+ "throw new UserException('works!');";
final String subst = "throw new UserException(\"$1\");";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}