import re
regex = re.compile(r"throw new UserException\('(.*)'\)")
test_str = ("throw new UserException('test');\n"
"throw new UserException('require');\n"
"throw new UserException('working');\n"
"throw new UserException('okay');\n"
"throw new UserException('regular');\n"
"throw new UserException('works!');")
subst = "throw new UserException(\"$1\");"
result = regex.sub(subst, test_str)
if result:
print(result)