#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "throw new UserException\('(.*)'\)"
Local $sString = "throw new UserException('test');" & @CRLF & _
"throw new UserException('require');" & @CRLF & _
"throw new UserException('working');" & @CRLF & _
"throw new UserException('okay');" & @CRLF & _
"throw new UserException('regular');" & @CRLF & _
"throw new UserException('works!');"
Local $sSubst = "throw new UserException("$1");"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)